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1 Introduction 

This manual describes the migration process between different versions of
Genova. 

Chapter 1 "Introduction" on page 1 is the chapter you are now reading. 

Chapter 2 "Moving from Genova 7.11 to Genova 8.0" on page 2 describes how to
migrate from Genova version 7.11 to Genova version 8.0. 

Chapter 3 "Moving from Genova 8.0 to Genova 8.1" on page 7 describes how to
migrate from Genova version 8.0 to Genova version 8.1. 

Chapter 4 "Moving from Genova 7.11 to Genova 8.1" on page 9 describes how to
migrate from Genova version 7.11 to Genova version 8.1. 

Chapter 5 "Moving from Genova 8.1 to Genova 8.2" on page 10 describes how to
migrate from Genova version 8.1 to Genova version 8.2. 

Chapter 6 "Moving from Genova 8.2 to Genova 8.3" on page 12 describes how to
migrate from Genova version 8.2 to Genova version 8.3. 

Chapter 7 "Moving from Genova 8.3 to Genova 8.4" on page 15 describes how to
migrate from Genova version 8.3 to Genova version 8.4. 

Chapter 8 "Moving from Genova 8.4 to Genova 8.5" on page 16 describes how to
migrate from Genova version 8.4 to Genova version 8.5. 

Chapter 9 "Moving from Rational Rose to Enterprise Architect" on page 17 describes
how to move a model from Rational Rose to Enterprise Architect. 
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2 Moving from Genova 7.11 to Genova 8.0

This chapter describes how to move from Genova version 7.11 to Genova
version 8.0.

None of the database files holding setup, resources or workspaces are com-
patible between the two versions of Genova. For workspace and resource
databases a conversion from Genova 7.11 to Genova 8.0 is needed. For set-
up databases, no such conversion is available. The new setup database for
Genova 8.0 has to be manually edited. 

The conversion of resources and workspaces is done by the export func-
tionality of Genova 7 to generate a XML based export file (workspaces/Ex-
port to XML). The exported resources and workspace are then imported
into Genova 8 databases with the import functionality of Genova 8 (File/
Import from XML).

Note: To export the workspace correctly, be sure you have the latest ver-
sion of Genova version 7.11. You may contact Genova support to
get the correct version or download it from http://www.esito.no.

The conversion of resources and workspaces are done in two export/import
steps, first do the resource database, then the workspace itself. 

2.1 Exporting the resource database

In Genova 7:

• Choose “Workspace/Export to XML/Resources”.

A file selection dialog is opened.

• Select the resource database (.rdb) you want to export and click “Open”.

A file save dialog is opened.

• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. It ends with a message box telling the result of the export.

• Click “OK”

2.2 Exporting the workspace

In Genova 7:

• Open the workspace you want to export: “Workspace/Open”.

• Choose “Workspace/Export to XML/Workspaces”

A file save dialog is opened.

http://www.esito.no
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• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. It ends with a message box telling the result of the export. 

• Click “OK”

Note: If you have a large workspace with many object selections, dialog
models and database mappings, the export may take several hours.

When you have both the resource databases and the workspaces exported
to XML files, these can be imported into Genova 8. Start with the resource
database.

Genova UI Title and Genova UI Field Length can be overridden in the Gen-
ova object selection models. Genova 7 workspaces has implicit overrides
on this. The overrides should be removed when migrating to Genova 8.
They should be removed from the XML export files before importing into
new workspaces. 

2.3 Importing the resource database

In Genova 8:

• Choose “File/Resource/New”

A new empty resource database is created.

• Choose “File/Import from XML”

A file open dialog is opened

• Select the XML file where the resource database was saved and click
“Open”

The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the resource database

• Choose “File/Resource/Save”

A file save dialog is opened and you choose a name for this new resource
database. You are recommended to use .grd as file type.

2.4 Preparing the setup database

Before importing the workspace you should edit the setup database to suite
your project. The most import issues are the four “Behavior” entries and the
default targets for the Client Designer and the Database Designer.

• Behavior:

Autocreate object selections

Add-in properties
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Default role name in Object Selection

Case sensitive names in Dialog Designer

• Dialog Designer

Standard_Styleguide

Default client target

• Database Designer

Default access target

Default schema target

Ancestor column name

In the setup for the database you also need to set the correct values defining
your database schema target(s).

• Database Designer

DBMS Schema Generation

The most important ones are those defining type mapping and locking.

To edit the setup database in Genova 8:

• Choose “File/Setup/open”. 

A file open dialog for the setup database is opened. 

• Select the setup database distributed with Genova 8 and click “Open”. 

The setup database is opened. 

• Right click on the root entry (Setup) and choose “Properties” from the
popup menu.

The property dialog for the setup database is opened. 

• Select the “User” row in this dialog. 

A Combo box is displayed in the right field of the selected row. 

• Choose “Default” user in the combo box. 

• Click “OK”. 

The root entry in the setup database displays: setup (Default). 

You are now ready to edit the default entries in the setup database. The val-
ues displayed are the values given as default to any user.

Do the needed editing. The entries in the setup database are edited in the
same way as you changed the default name, via the property dialog for each
entry. 
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You are recommended to save the edited setup database under a new name,
keeping the original unchanged: 

• Choose “File/Setup/Save As”. 

A file save dialog for the setup database is opened. 

• Select a new name, using the .gsd as file type. 

• Click “Save”. 

2.5 Importing the workspace database

In Genova 8: 

• Choose “File/New workspace”

At this point you must choose which setup and resource database the work-
space should use. If these databases are already open the program will ask
if you want to use them. If not, file dialogs will prompt you for the databas-
es.

A new empty workspace is created.

• Choose “File/Import from XML”

A file open dialog is opened

• Select the XML file where the workspace from Genova 7 was saved and
click “Open”.

The import starts. A progress bar shows the amount of data imported.

When the export is ended you need to save the workspace

• Choose “File/Save workspace”

A “Save as” workspace dialog is opened and you choose a parent directory
for the workspace (the default is “%GENOVA8_HOME%\Workspaces”). 

• Enter the name of the new workspace.

This name will be used both as a sub-directory name and as the name of the
workspace file itself. Don’t use any file type when choosing a name. The
name “MyWorkspace” will give you a directory: 

%GENOVA8_HOME%\Workspaces\MyWorkspace

and the workspace file itself will be saved as 

MyWorkspace.gws

in this directory.
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• Click “OK” to save the workspace.

Note: The save action could take some minutes, depending on the number
of object selections, dialog models and database mappings con-
tained in the imported workspace.

Genova 8 saves each object selection, dialog model and database mapping
in separate files. All these files will be found in the same directory as the
workspace file (.gws-file).
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3 Moving from Genova 8.0 to Genova 8.1

This chapter describes how to move from Genova version 8.0 to Genova
version 8.1.

Between these two versions the workspace and the setup databases are
compatible. But the resource databases are not, they need to be converted. 

The conversion of resources is done by the export functionality of Genova
8.0 to generate a XML based export file (File/Export to XML). The export-
ed resources may then be imported into Genova 8.1 with the import func-
tionality (File/Import from XML).

Note: To export the resources correctly, be sure you have the latest ver-
sion of Genova version 8.0, i.e. at least version 800C. You may
contact Genova support to get the correct version.

Although the two versions of the setup database are compatible, you are
recommended to change to the setup database delivered with Genova ver-
sion 8.1 as it contains new setup entries. To do so you must manually edit
the new setup database with your settings in the version 8.0 setup. 

3.1 Exporting the resource database

In Genova 8.0: 

• Open the resource database you want to export: “Workspace/Resource/
Open”.

• Choose “File/Export to XML

A file save dialog is opened. 

• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. A progress bar shows the amount of data exported. 

3.2 Importing the resource database

In Genova 8.1:

• Choose “File/Resource/New”

A new empty resource database is created.

• Choose “File/Import from XML”

A file open dialog is opened

• Select the XML file where the resource database was saved and click
“Open”
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The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the resource database

• Choose “File/Resource/Save”

A file save dialog is opened and you choose a name for this new resource
database. You are recommended to use .grd as file type.
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4 Moving from Genova 7.11 to Genova 8.1

This chapter describes how to move from Genova version 7.11 to Genova
version 8.1.

Genova 8.1 imports both 7.11 workspaces and resources. Because of this
there is no need to go via the Genova version 8.0 when converting from
Genova 7.11 to Genova 8.1. 

The exporting and importing of resource databases and workspaces are per-
formed as described in the chapter describing the migration from Genova
7.11 to Genova 8.0 (see chapter 2 on page 2).
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5 Moving from Genova 8.1 to Genova 8.2 

This chapter describes how to move from Genova version 8.1 to Genova
version 8.2. 

Between these two versions the workspace database is compatible. The old
setup database may still be opened in the new Genova version, but the con-
tent has changed. The resource databases are not compatible, they need to
be converted. 

The conversion of resources is done by the export functionality of Genova
8.1 to generate a XML based export file (File/Export to XML). The export-
ed resources may then be imported into Genova 8.2 with the import func-
tionality (File/Import from XML).

Although the two versions of the setup database are compatible, you are
recommended to change to the setup database delivered with Genova ver-
sion 8.2 as it contains new setup entries. To do so you must manually edit
the new setup database with your settings from the version 8.1 setup. 

5.1 Exporting the resource database

In Genova 8.1: 

• Open the resource database you want to export: “Workspace/Resource/
Open”.

• Choose “File/Export to XML

A file save dialog is opened. 

• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. A progress bar shows the amount of data exported. 

5.2 Importing the resource database

In Genova 8.2:

• Choose “File/Resource/New”

A new empty resource database is created.

• Choose “File/Import from XML”

A file open dialog is opened

• Select the XML file where the resource database was saved and click
“Open”

The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the resource database
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• Choose “File/Resource/Save”

A file save dialog is opened and you choose a name for this new resource
database. You are recommended to use .grd as file type.
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6 Moving from Genova 8.2 to Genova 8.3 

This chapter describes how to move from Genova version 8.2 to Genova
version 8.3. 

The main difference between Genova 8.2 and Genova 8.3 is that version
8.2 stores all of the data (workspace, setup and resources) in object data-
bases, while  version 8.3 stores all of the data in XML-files. None of the da-
tabase files from Genova 8.2 can be used by Genova 8.3. 

The conversion of the object databases is done by the export functionality
of Genova 8.2.1 to generate XML based export files (File/Export to XML).
The exported databases may then be imported into Genova 8.3 with the im-
port functionality (File/Import from XML). 

Note: The XMLs should be produced with Genova version 8.2.1.B or
newer. This 8.2 version of Genova contains commands for export-
ing workspace, resource and setup databases. 

Genova 8.3 comes with both a resource and a setup database. To convert
your databases you may either update the distributed versions with your
own settings, or you may follow the export/import pattern described below. 

6.1 Exporting the resource database 

In Genova 8.2.1.B: 

• Open the resource database you want to export: “Workspace/Resource/
Open...” 

• Choose “File/Export to XML/Resource...” 

A file save dialog is opened. 

• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. A progress bar shows the amount of data exported. 

6.2 Importing the resource database

In Genova 8.3: 

• Choose “File/Resource/New”

A new empty resource database is created.

• Choose “File/Import from XML/Resource...”

A file open dialog is opened

• Select the XML file where the resource database was saved and click
“Open”
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The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the resource database

• Choose “File/Resource/Save” 

A file save dialog is opened and you choose a name for this new resource
database. You are recommended to use .grdx as file type.

6.3 Exporting the setup database 

In Genova 8.2.1.B: 

• Open the setup database you want to export: “Workspace/Setup/Open”.

• Choose “File/Export to XML/Setup...” 

A file save dialog is opened. 

• Select the XML file where the export should be saved or write the name
of a new file and click “Save” 

The export starts. A progress bar shows the amount of data exported. 

6.4 Importing the setup database

In Genova 8.3: 

• Choose “File/Setup/New”

A new empty setup database is created.

• Choose “File/Import from XML/Setup...”

A file open dialog is opened

• Select the XML file where the setup database was saved and click
“Open”

The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the setup database

• Choose “File/Setup/Save”

A file save dialog is opened and you choose a name for this new resource
database. You are recommended to use .gsdx as file type.

6.5 Exporting the workspace 

In Genova 8.2.1.B: 

• Open the workspace you want to export: “Workspace/Open work-
space...” 

• Choose “File/Export to XML/Workspace...” 
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A file save dialog is opened. 

• Select the XML file where the export should be saved or write the name
of a new file and click “Save”.

The export starts. A progress bar shows the amount of data exported. 

6.6 Importing the workspace 

In Genova 8.3:

• Choose “File/New workspace...” 

• Choose the 8.3 setup file to use. 

• Choose the 8.3 resource file to use. 

A new empty workspace is created.

• Choose “File/Import from XML/Workspace...”

A file open dialog is opened

• Select the XML file where the resource database was saved and click
“Open”

The import starts. A progress bar shows the amount of data imported.
When the export is ended you have to save the resource database

• Choose “File/Save workspace”

A file save dialog is opened and you choose a name for this new workspace.
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7 Moving from Genova 8.3 to Genova 8.4 

This chapter describes how to move from Genova version 8.3 to Genova
version 8.4. 

There are format changes in the Genova workspace from 8.3 to 8.4. How-
ever, a Genova 8.3 workspace is readable with Genova 8.4. Saving the
workspace with Genova 8.4 results in a new format. It is not possible to
read 8.4 format with Genova 8.3.
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8 Moving from Genova 8.4 to Genova 8.5 

This chapter describes how to move from Genova version 8.4 to Genova
version 8.5. 

There are format changes in the Genova workspace from 8.4 to 8.5. How-
ever, a Genova 8.4 workspace is readable with Genova 8.5. Saving the
workspace with Genova 8.5 results in a new format. It is not possible to
read 8.5 format with Genova 8.4.
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9 Moving from Rational Rose to Enterprise Architect 

As of version 8.2, Genova supports modeling in Enterprise Architect, as
well as Rational Rose. This chapter describes the steps that need to be taken
to successfully move a model from Rational Rose to Enterprise Architect
(EA). We recommend that the latest Genova version is used.

Please follow these instructions exactly as written, and do not omit any-
thing or change order of the activities. Failure to do so will usually result
in non working application and code.

Before starting, make sure the following requirements are met: 

• Genova 8.2 or newer 

• EA 7.1.832 or newer 

• XMI Add-in 1.3.9 for Rational Rose (Information is given at this URL: 
http://www.sparxsystems.com/support/faq/import_rose_model.html) 

1) Prepare directory structure: It is convenient to define a directory
structure that contains both the model to convert and the converted
model: e.g.:

..\models

..\models\”RoseModel” 

..\models\”RoseModel”\databasemappings (created when defining workspace)

..\models\”RoseModel”\dialogmodels (created when defining workspace)

..\models\”RoseModel”\objectselections (created when defining workspace)

..\models\”EAModel” (included subdirectories above)

The models directory may contain the model files (Rose *.mdl. and EA
*.eap), the Genova setup file and the Genova resource file.

The “RoseModel” directory contains the Genova Rose workspace
(.gwsx) file and other specific files and subdirectories for the Rose
workspace. 

The “EAModel” directory will contain the Genova EA workspace and
other specific files and sub directories for the EA workspace, when the
migration is completed.

1) Check the model consistency: Genova uses specific information from
the UML model. Some property settings may generate errors in the des-
tination model, if the values are incorrect, even if it seemed to be correct
in the source model. This can be avoided using the Genova Consistency
checker. This is achieved by running a Rose script from Rose tools
menu. Select the Tools > Genova DB > Check Model Consistency...
menu in Rose. See section 8.3 on page 53 in the Rose Add-Ins manual.

If the cardinality on associations are missing, it will create errrors in the
destination model. 

http://www.sparxsystems.com/support/faq/import_rose_model.html
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2) Prepare the model for export: Genova depends on some stereotypes
that are default in Rose to be set explicitly. This is achieved by running
a Rose script that is included in the Genova release. 

• Start Rose and open the model you wish to export. 

• Open the script by selecting Tools › Open Script, and selecting 
SetStereotypes.ebs from the Rational Rose installation directory,
normally: C:\Program Files\Rational\Rose\Genova. 

• Run the script. 

3) Export the model to XMI: Select Tools › UML - XMI › UML 1.3 › Ex-
port to XMI. Press OK, and then provide a filename for the XMI file.  

4) Transform the XMI: Some elements in the XMI file need to be re-
moved or transformed before they are imported into EA. This task is
done by a java class shipped with Genova. Simply run:

java -jar "%GENOVA8_HOME%\misc\RoseXmiToEa.jar" -i inputfile -o outputfile

You need to replace inputfile with the actual file name of the XMI file
exported from Rose, and outputfile with the desired filename for the
modified XMI. 

5) Import the XMI into EA: The XMI is now ready to be imported into
an EA project. 

• Start Enterprise Architect, and create a new project. 

• Import the UML profiles Genova and GenovaGroup, BEFORE im-
porting the model. 
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• Select Project › Import/Export › Import package from XMI. 

• Click the Import button. 

6) Tidy up the imported model: Move component view and use cases to
appropriate views in the EA project. Please move packages directly by
dragging and dropping them in the EA project browser. Do not copy di-
agrams with the UML elements included (deep copy) or any other ob-
scure method (e.g. XMI export and import).

7) Restore package hierarchy: In Rose, the package hierarchy of the
classes is given by the component view of the model. If this structure
differs from the logical view (which dictates the class hierarchy in EA),
the classes in the logical view need to be restructured for the original
class hierarchy to survive the migration. 

8) Bug work-around: The currently latest version of EA (7.5.847) con-
tains a bug that may cause missing methods, or methods in wrong order.
To eliminate this problem, open all methods in EA, one after one, and
click the Save button. Skip this step if the bug has been removed in the
EA release you are working with. Hint: All classes with methods in EA
can be found by selecting “edit, find in model”, search term “*” and
search for “Method details”. 

9) Package-level visibility: When synchronizing from Rose, Genova in-
terprets "Implementation" visibility as package. However, the XMI ex-
port treats this as private. Therefor, all attributes and methods that
should have package visibility need to be modified to restore their in-
tended visibility.

10) Start a new Genova workspace: Start Genova, and create a new
workspace in the “EA Model” directory. 
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11) Synchronize: We are now ready to synchronize the workspace with
the model in EA. 

• Set up Genova to synchronize against EA. This is done by clicking
Edit › Option, then selecting Enterprise Architect from the modeling
tool drop-down menu. 

• Select File › Set model, and select the correct EA project file. 

• Turn off the Autocreate object selections setting located under the
Behavior folder in the setup browser. 

• Turn off the Use Component View package when generating code
setting  located under the Behavior folder in the setup browser. 

• Click the Synchronize button in Genova. This will bring up the fol-
lowing dialog; 

• Type in the correct path and click OK.

12) Import object selections and dialog models: 

• Right-click Object selections in the workspace browser. 
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• Select Import object selections. This will bring up the following di-
alog. 

• Multi-select the object selections you wish to import (normally, this
is all object selections), and click Open. 

• Repeat this step for dialog models. 

13) Transfer Database mappings: To transfer a database mapping, it
must first be recreated in the new workspace. Then the overrides in the
old database mapping may be imported. 

• In the old workspace: Open the database mapping and save its over-
rides to file (see "Saving and loading overrides" on page 82 in the
Database Designer manual). 

• Create a new database mapping in the new workspace and rename it
to match the one in the old workspace (see "Creating a new database
mapping" in section 4.3 in the Database Designer manual). 

• Open the new database mapping, and set the same Data Access and
DBMS Schema as in the old mapping. 

• Load the saved overrides into the new database mapping. 

• Save and close the database mapping. 
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14) Import Sysdul objects: If the workspace contains Sysdul objects,
these must also be imported into the new workspace. 

• Right-click Sysdul objects in the workspace browser. 

• Select Import Sysdul Objects. This will bring up the following dia-
log. 

• Select the Sysdul object database you wish to import (each work-
space has only one), and click Open.

15) It is a good idea to verify that the converted application code can be
generated without errors and the converted applications actually works. 
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