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1 Introduction
This manual is intended to provide an introduction to the functionality and features of g9's Web Services
capabilities and demonstrate modeling and code generation with WSg perspective. WSg is a subset of g9, a domain
driven application development tool. It consists of a series of plug-ins used in the Eclipse open development
platform providing a modern integrated development environment (IDE).
Getting Started with WSg is a step by step description on how to utilize domain models with classes and interfaces
to create/generate the Web Service plumbing between a client consuming services and a server offering those
services. The example consists of multiple projects:
•
•
•
•

Client project with code for the client written as junit tests
Server project with the service implementations run as a web application
Domain project common for the client and server, housing the domain classes (Initially it is empty)
Model project with the domain model, specific WSg models and code generation capabilities

The 4 projects could have been organized as one combined project but it is better practice to divide the example
into projects with different purposes.
You will start with a simplistic domain model in form of an Xcore file intended to depict many aspects of using Web
Services. You will import initial projects containing runnable code for services and a test client that uses those
services. Accompanying the Eclipse projects will be Maven POM files for resolving any dependencies and ensuring a
proper compilation. You will also extend a provided service to create a new Web Service.
The tutorial is not meant as a guide for implementing a real-world application. Rather, it is meant to show the
power and flexibility of WSg for creating Web Services and for generating code.

1.1 Prerequisites
Before you begin to work with the sample application, ensure that you have the following in place:
• Download and install Eclipse IDE for Java and DSL Developers version Neon. This includes EMF and Xcore
tools. The domain model is provided as an Xcore file; Read about Xcore: http://wiki.eclipse.org/Xcore
• Ensure that you have a Java runtime environment (JRE) (Java SE 8 or greater)
• Install the g9 Eclipse plugin (latest version) using the update site http://www.esito.no/updatesite/g9. This
also installs the Getting Started example project.
• Install the g9 Runtime.

1.2 Installing g9
The installation of g9 is performed using the Eclipse Update site installation.
1. Start Eclipse. This presents a ‘Select a workspace” dialog and defaults to the current logged-in user
directory. (C:\Users\[Windows user name]\workspace). Press enter to accept this directory or enter another
directory of your choice.
2. In Eclipse, the Welcome screen is displayed. From the main menu, select the menu option Help > Install New
Software...
3. In the Install dialog, click the Add... button located at the top right of the dialog to add an install site. This
brings up the Add Repository dialog.
4. Install the most recent version from the remote update site.
a. In the Name field, type g9 update
b. In the Location field, type http://www.esito.no/updatesite/g9
5. Select Esito Modeling tools and click Next > and Next >
6. Read and accept the license agreement. To continue installing, select "I accept the terms of the license
agreement" and click Finish.
7. Click OK in the Security Warning if it is displayed.
8. When prompted to restart Eclipse, click Restart Now to restart.
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1.3 Install g9 runtime
The sample projects use code from g9 run-time libraries which are available from the Maven Central repository.
If you can't access the Maven Central, you may install the jar files into your local Maven repository: Select
Window>Preferences and then select the g9 entry.

Click the Installation of g9 runtime files link. This displays a dialog showing the location of the Maven installation
script and it also copies the location into the clipboard. Select OK to close the g9-Runtime dialog and then Cancel
to close the Preferences dialog.
Select the menu option Run>External Tools>External Tools Configurations... from the main menu.
Click the Program node in the tree view and then select the New launch configuration button
. Paste the
clipboard content into the Location and Working Directory fields. Add \maven-install.cmd to the end of the
Location. Give the configuration a name:

Introduction

Page 5 of 31

g9 - Using the WSg perspective

Click Apply and Run. The run-time libraries are installed into your Maven repository and the result is shown in the
Console view.

Introduction
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2 WSg Introduction
2.1 Overview
Following the domain driven development approach to software development, g9 is a development environment
that can manage the complexities of application development. It can import a domain and application model into
its workspace and add abstract data and user interface modeling (dialog modeling). The WSg perspective gives a
subset of g9 that contains the tools necessary for the creation of web service objects and for the generation of java
code for consuming and creating Web services.
g9 is a plug-in to the Eclipse development platform. Eclipse is an open source platform that has multiple projects
that provide extensible framework, tools and run-times for building, deploying and managing software across the
life-cycle.
With g9 you can build complete java enterprise applications without any other programming than your necessary
business logic. WSg focuses on support for developing Web Services. The g9 concepts are

g9 artifact

Description

Domain model

Application concepts defined as domain/class models in
Enterprise Architect UML, EMF/Xcore or Java source
Domain models. The model is synchronized into the g9
workspace.

Database model

Representation of the persistent part of the domain model
suitable for database modeling.

Object Selection

Subset of the Domain model. Selected objects and
association roles from the domain model. The subset
supports a use case/task.

Dialog template

Resources and guide lines for user interface design.

Dialog model

User interface design based on Object Selections and
Dialog templates.

WSg Introduction
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From the models, can g9 generate database schemas, object-relational mappings, java domain classes, java CRUD
services on any subset of the model, and applications and clients based on Swing or JSF/ICEfaces frameworks. The
generated results may form a complete application from client to database.
WSg uses only the Domain and Object Selection models and generates code based on those models. In this quick
start guide, you will build a simple application based on a car/owner domain model. You will import the model into
the workspace, model object selections, bind Web Service parameters to objects/attributes and finally, you will
generate code supporting use of the Web Services.

2.1.1 Eclipse IDE and WSg
As an IDE, Eclipse is a platform for tool integration and hosts several ongoing projects designed to add greater
functionality. WSg works seamlessly with the Java DSL Tools project which supports the development on any Java
application. The Eclipse IDE for DSL Developers with the g9 plugin, WSg perspective, some models and Xcore files
may be as shown here:

WSg Introduction
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A perspective is a group of views and editors in the Workbench window. Initially, the Java perspective is displayed
(as can be seen by the Java button at the top right). Here the WSg perspective is selected and shown.
A view is a visual component within the workbench. It is typically used to navigate a list or hierarchy of information
or display properties for the active editor. Some views have a pull-down menu or a toolbar and they can easily be
resized, repositioned and stacked on other views. To reposition a view, click down on the tab and drag and drop it
to any other position within the workbench. Select the Window>Reset Perspective menu to reset a perspective to its
original look.
An editor is also a visual component within the Workbench. It is typically used to edit or browse a resource. The
visual presentation might be text or a diagram. Typically, editors are launched by clicking on a resource in a view.
For more information on using Eclipse, see the online help at http://help.eclipse.org or you can select the Help>Help
Contents menu.

WSg Introduction
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3 Creating the WSg Getting Started Projects
3.1 Introduction
The g9 Web Services projects allows for the creation of web service objects and for the generation of java code for
consuming and creating Web services. Included with the plug-ins is a WSg example project that makes it easy to
illustrate the WSg capabilities. It contains a pre-defined Wsg project along with associated java projects that
contain pre-generated code. In this tutorial you will perform various tasks:
• Import a g9 Web Service project along with 3 Java projects that contain the written and generated code
• Synchronize the WSg project with a predefined Xcore model that will be used to update the Domain Model
• Examine the Object selections which will be used to specify the sub-set of classes that comprise the
information model used by a service
• Examine the binding of the object selections with the interfaces defined in the Domain Model

3.2 Example Model
In this tutorial, you will use a predefined model for retrieving information about car owners and their cars. An
Owner has one or more cars and a Car has only one CarModel. In addition to the definition of the domain classes,
the model also contains an interface defining various methods that will be used for retrieving information from the
model. The getOwners method returns a Set containing all Owners. The getOwnersWithCars method returns all Car
objects with it's CarModel information given a specific Owner.

3.3 Importing the WSg Example Projects
You will now import the example projects into your workspace.

Creating the WSg Getting Started Projects
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1. Start Eclipse and select the menu option File>New>Example...

2. Go to the g9 Examples, select the WSg Start node and click Next.

3. Click Finish and the 4 projects will be created. All projects are complete and runnable. In the following
sections we will look at the artifacts that comprise the WSg projects and run the server and client
applications. If you have Automatic build turned on, the projects will be populated with all necessary Maven
artifacts and compiled.

Creating the WSg Getting Started Projects
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4. The Import Example does not always build correctly. If so, select all projects, perform close projects and
open projects and it should build correctly.

3.4 Investigating the Java Projects
You now have 3 java projects that contain both hand-coded and generated code. Maven is used to simplify the
resolution of the dependencies required for the generated code.

ws-domain

This common domain project will contain code for the domain/transport
classes

ws-service

This project will contain the implementation of the services

ws-client

This project will contain the client code using the services

You may switch to the Java Perspective if it is not already selected by selecting the Open Perspective button on the
toolbar.
Your java projects should display in the Package Explorer with Java and Maven nature:

3.5 Investigating the WSg Project
A g9 Web Services project stores web service objects including the domain classes and interface models. The wsmodel project in the Package explorer contains an application based on an existing domain model described in
Xcore. Switch to the WSg perspective to investigate the models. The WSg project has the WSg and Xcore nature. The
image shows a Domain model with Classes, Interfaces and Object Selections.

Creating the WSg Getting Started Projects
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3.6 Synchronizing the domain model (Xcore)
 Xcore is a domain specific language (DSL) for describing Ecore models. More Xcore information is available
at:
http://wiki.eclipse.org/Xcore#Getting_Started
WSg supports domain models represented as UML models created with Enterprise Architect, or models created as
an Xcore file. The Xcore format is basically a sub-set of UML class diagrams and is part of the Eclipse EMF project.
In this Getting Started example, we provide you with an Xcore model called Domain.xcore/Service.xcore that
contains the domain class and interface information. You will then synchronize the project with the domain model.
Although the example provides a project that is already synchronized, we will nevertheless take you through the
steps.
1. Expand the ws-model project node and double-click the xcore/Domain.xcore file to open up an editor
displaying the contents. You may browse its contents that shows definition of Classes, Attributes and g9
Annotations.

Creating the WSg Getting Started Projects
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2. Right-click on the ws-model project and select the Properties menu. Expand the g9 node and select the
Domain Model node.

Creating the WSg Getting Started Projects
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3. Select the Cars Domain Model Source and click Edit...

Creating the WSg Getting Started Projects
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4. Press the Fetch Package Structure button. This updates the tree view structure containing the domain
model packages. Press OK twice and finish the dialog.
5. Select the ws-model project and select the g9>Domain Model Update... menu. The Domain Model Update
dialog opens up with all packages selected. Click the Finish button to complete the synchronization.
You may now explore the Domain model Classes and Interfaces in the ws-model project.

3.7 Creating Object Selections
An object selection is a subset of a class model, specifying classes that comprise the information model used by a
service. In this example, we will be creating two object selections that will be used by the web services. The
following tasks are meant to illustrate how you would have created these objects if they didn't exist. Since these
objects already exist, you cannot add them.

3.7.1 Create Object Selection getOwners:
1. Right-click the Object Selections node in the ws-model project and select Add>Object Selection... This
opens the New Object Selection dialog.
2. Enter getOwners in the Object Selection name field and press the Finish button. This opens an Object
Selection editor.

Creating the WSg Getting Started Projects
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3. In the Object Selection editor, right-click the root node getOwners and select Add Role>Owner.
4. In the Add Owner dialog, accept the entry Owner and press the OK button.
5. The Owner role should appear as a node under the root node. Save the object selection by typing Ctrl+S.

3.7.2 Create object selection getCars:
1. Right-click the Object Selections node in the ws-model project and select Add>Object Selection...
2. Enter getCars in the Object Selection name field and press the Finish button. This opens an OS editor.
3. In the OS editor, right-click the root node getCars and select Add Role>Owner. In the Add Owner dialog,
accept the entry Owner and press the OK button.
4. Select the Owner node in the editor, right click and select Add Role>Car (owner_car:car). In the Add
Car dialog, accept the entry Cars and press the OK button.
5. Select the Cars node in the editor, right click and select Add Role>Model (carModel_car:carModel). In
the Add Model dialog, accept the entry CarModel and press the OK button.
6. Save the Object Selection.

3.8 The Binding of parameters
We will now bind the object selections created in the previous section with the interfaces defined in the domain
model. The binding can be performed directly in the properties view for the Interface Quickstart. Included in the
interface are 3 methods with different signatures. You will now browse the Quickstart interface containing the 3
methods and define the bindings:

Creating the WSg Getting Started Projects
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Expand the Model View, Domain Model, Interfaces and Quickstart nodes and click the Interfaces signatures one at
a time:
helloWorld
This method is a traditional method that outputs the string "helloWorld". It has no parameters and returns a
String.
1. Select the helloWorld signature and observe the properties in the Properties view.
Notice the Model Type is set to String indicating it's return-value. There is no other binding required.

3.8.1 getOwners
This method returns a java Set containing a collection of Owner classes. It has no parameters. You will now
bind the getOwners method to the getOwners object selection that was previously created.
1. Select the getOwners signature.
2. Enter the following values in the Properties view:

General/Binding

Property

Value

ObjectSelection

getOwners

OS Role

Owner

Occurence

0..*

3.8.2 getOwnerWithCars
This method contains an input parameter called name which is the name of an Owner. It returns an Owner
containing all owned cars of the specified owner.
1. Select the getOwnerWithCars signature.
2. Enter the following values in the Properties view:

Creating the WSg Getting Started Projects

Page 18 of 31

g9 - Using the WSg perspective

General/Binding

Property

Value

ObjectSelection

getCars

OS Role

Owner

Occurence

<Default> 1..1

3. Expand the signature, select the name parameter and enter the String Model Type.

Creating the WSg Getting Started Projects
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4 Generating the code
In this section you will generate the java code required for the web services. Once the code is generated, there will
still be some tailoring of the code required.

4.1 Separation of generated/manually maintained code
The generators supports splitting of generated and manually maintained code into two separate source
hierarchies. This behavior is triggered by setting the "Source directory" generator parameter to a different value
than the "Target directory" parameter. With this behavior, if a file is present in the "Source directory" it will not be
generated to the "Target directory". Default values are src-gen/main and src/main.

4.2 Understanding the Generator Configurations
WSg consists of a set of Generators, each one generating code for a specific purpose. The ws-model project uses 5
different Generators. To view the configurations:
Right-click the WSg ws-model project and select the Properties menu. Now click on the g9>Build node to display
the Generator Configurations property page.

Double-clicking a Generator Configuration shows the parameter definitions for the Generator:

Generating the code
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The parameters are described in detail in the Web Services Generator documentation.
The 5 generators produces code into the 3 java projects as follows:
1. The Java Domain builder generates all domain classes and interfaces into the ws-domain java project.
2. The Transport builder generates transport versions of all the domain classes and SOAP/Castor marshalling
also into the ws-domain project.
3. The WSClient builder generates the client side of the application into the ws-client project.
4. The WSDL builder generates the server side of the Web Services into the ws-service project.
5. The XSD builder generates the server side of the Web Services into the ws-service project.

4.3 Using the Maven dependencies
Before generating the code, we will check the Maven dependencies so the various projects will compile correctly
once the code is generated. This is accomplished by verifying the pre-created pom.xml files in the projects. Open
the pom files and click on the Dependencies tab and then click on a dependency and then click the Properties
button.

Generating the code
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4.3.1 ws-domain project
Group Id

Atrifact Id

Version

org.codehaus.castor

castor-xml

1.4.1

no.esito

g9-common

2.9.0 or newer

Group Id

Atrifact Id

Version

com.wsg.sample

ws-domain

1.0-SNAPSHOT

org.mortbay.jetty

jetty-maven-plugin

9.4.19.v20190610

org.eclipse.jetty.aggregate

jetty-all

9.4.19.v20190610

org.springframework.ws

spring-ws-core

2.4.6.RELEASE

4.3.2 ws-service project

4.3.3 ws-client project
Group Id

Atrifact Id

Version

junit

junit

4.12

com.wsg.sample

ws-domain

1.0-SNAPSHOT

org.springframework.ws

spring-ws-core

2.4.6.RELEASE

4.3.4 Update the Maven Projects
If you have errors in the Problems view stating the projects are not up-to date, do a Maven update as follows:
1. Select the client, domain and service projects, right click and select Maven/Update Project...
2. Ensure all 3 projects are selected and press the OK button.

4.4 Generating the Code
You will now generate the code which may be built per java project or as a whole. Right-click the WSg project node
and select Properties. Open the g9 folder and select Build. Four Build configurations are defined where one is set as
the Default Builder (called Standard). The Default Builder generates code for all projects, the Java domain classes

Generating the code
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and the web service code as specified in the Interface. The Client, Domain and Service Builders, generates code for
the three corresponding java projects. The Builders are shown below:

To generate the code, select the WSg perspective if it is not already selected by clicking the Open Perspective
button on the main toolbar and selecting the WSg node.

4.4.1 The Default Builder
1. Expand the ws-model project and Model View and Domain model folders.
2. Right-click the Domain model node and select the Build menu.

4.5 Exploring the Generated Code
Project

Location

Package/
directory

File

Notes

ws-client

src-gen/main/
java

com.wsg.sample
.service

QuickstartWSClien
t.java

Generated code

Generating the code
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Project

wsservice

Location

Package/
directory

File

Notes

src-gen/main/
resources

com\wsg\sampl
e\quickstart

ws-clientquickstart.properti
es

Generated once,
may be edited/
moved

ws-clientquickstart.xml

Generated code

ws-clients.xml

Generated once,
may be edited/
moved

src/test/java

com.wsg.sample
.test

TestQuickstart.jav
a

Junit test code,
manually written

src/main/java

com.wsg.sample
.service

NoSuchOwnerExc
eption.java

Implementation
utility, manually
written

QuickstartImpl.jav
a

Generated once,
moved and edited
with service code

QuickstartEndpoin
t.java

Generated code

jetty-config.xml

Manually written

log4j2.xml

Manually written

ws-addedcontext.xml

Generated once,
may be edited and
moved

ws-interceptorscontext.xml

Generated once,
may be edited and
moved

wsservlet.properties

Generated once,
may be edited and
moved

src-gen/main/
java

com.wsg.sample
.service.generate
d

src/main/
resources

src-gen/main/
resources

Generating the code
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Project

Location

Package/
directory

src-gen/main/
webapp/WEBINF

com/wsg/
sample/
quickstart

wsdomain

src/main/java

src-gen/main/
java

com.wsg.sample
.domain

com.wsg.sample
.domain

com.wsg.sample
.os.getcars

Generating the code

File

Notes

web.xml

Generated once,
may be edited and
moved

ws-servlet.xml

Generated code

Quickstart.wsdl

Generated code

getCars_Owner.xs
d

Generated code

getOwners_Owner
.xsd

Generated code

quickstartSchema.
xsd

Generated code

Car.java

Generated once,
moved and may be
edited

Model.java

Generated once,
moved and may be
edited

Owner.java

Generated once,
moved and may be
edited

CarDefault.java

Generated code

ModeDefaultl.java

Generated code

OwnerDefault.java

Generated code

CarModelRole.java

Generated code

CarsRole.java

Generated code

GetCarsConst.java

Generated code
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Project

Location

Package/
directory

com.wsg.sample
.os.getowners

com.wsg.sample
.quickstart.getca
rs

com.wsg.sample
.quickstart.geto
wners

com.wsg.sample
.service

Generating the code

File

Notes

OwnerRole.java

Generated code

package-info.java

Generated code

GetOwnersConst.j
ava

Generated code

OwnerRole.java

Generated code

package-info.java

Generated code

CarModelTranspor
t.java

Generated code

CarModelTranspor
tConverter.java

Generated code

CarsTransport.jav
a

Generated code

CarsTransportCon
verter.java

Generated code

OSHolder.java

Generated code

OwnerTransport.ja
va

Generated code

OwnerTransportC
onverter.java

Generated code

OSHolder.java

Generated code

OwnerTransport.ja
va

Generated code

OwnerTransportC
onverter

Generated code

Quickstart.java

Generated code
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Project

Location

Package/
directory

File

Notes

QuickstartPayload
.java

Generated code

castor.properties

Generated once,
may be edited and
moved

commoncastormapping.xm
l

Generated code

quickstart-servicecastormapping.xm
l

Generated code

transportcontext.xml

Generated once,
may be edited and
moved

ws-marshallercontext.xml

Generated once,
may be edited and
moved

com\wsg\sampl
e\quickstart\
getCars

getCars_Ownertransportcastormapping.xm
l

Generated code

com\wsg\sampl
e\quickstart\
getOwners

getOwners_Owner
-transportcastormapping.xm
l

Generated code

src-gen/main/
resources

com\wsg\sampl
e\quickstart

Generating the code
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5 Add implementation and run the sample application
You will now add/inspect the manually written implementation code to the various projects to test the web service
code.

5.1 Inspect the client code
The client is implemented as a JUnit class (TestQuickstart.java). This is a hand coded JUnit class file that was
added to the example for you to test the web services.
1. Expand the ws-client project and browse to the src\test\java and select the package
com.wsg.sample.test.
2. Open the TestQuickstart.java file in the editor.

5.2 Inspect the server code
The services are implemented in the file QuickstartImpl.java class (contained in the
package com.wsg.sample.service under the src/main/java directory). It contains code that populates owners and
cars.
1. Expand the ws-service project and browse to the src\main\java and select the package
com.wsg.sample.service.
2. Open the QuickstartImpl.java file in the editor.

5.3 Code added to the domain project
In the Owner.java class, the following constructor has been added in addition to the default constructor.

public Owner(int id, String name, boolean driver) {
setId(id);
setName(name);
setDriver(driver);
}

In the Car.java class, the following constructor is added in addition to the default constructor:

public Car(String registrationNumber, String color) {
setRegistrationNumber(registrationNumber);
setColor(color);
}

In the Model.java class, the following constructor is added in addition to the default constructo:

public Model(int id, String manufacturer, String type, int productionYear) {
setId(id);
setManufacturer(manufacturer);
setType(type);
setProductionYear(productionYear);
}

Add implementation and run the sample application
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5.4 Compile and run
1.
2.
3.
4.
5.

Before running the web services, ensure that your java compiler is using at least Java 1.6.
Compile the projects.
Run the server with the predefined launch script: ws-JettyStart.launch.
In the Java perspective, select Run Configurations... from the Run menu.
From Java Application, select the ws-JettyStart application and press the Run button.

6. Right-click on the ws-client project and select Run As>Junit Test. The JUnit class TestQuickstart is showing
the status on the junit assertions.

Add implementation and run the sample application
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6 Extend with new service
In the following you will add a service and an unit test to the application, define necessary model elements,
generate code and run the the server and application tests.

6.1 Add signature to the Interface
We want to make a new service similar to getOwnerWithCars, where we change the input parameter from String to
an Owner object.
1.
2.
3.
4.
5.
6.

Open the Service.xcore file in the ws-model project
Copy the op Owner getOwnerWithCars(String name) line
Change the method name to getCarsFromOwner
Change the input parameter to Owner owner
Giving this: op Owner getCarsFromOwner(Owner owner)
Save the file

6.2 Syncronize the model changes
1.
2.
3.
4.

Switch to the WSg perspective
Select the ws-model project root
Run the Project > Domain Model Update... menu
Inspect the Domain Model Interfaces

6.3 Bind the parameters
1.
2.
3.
4.
5.

Double click the getCarsFromOwner method
Create a binding similar to the getOwnerWithCars method
Select the owner prarameter and bind the same object selection and role class (getCars with the Owner role)
Generate the new Interface: right click the Quickstart interface and select Build Other Domain
Inspect the Interface code

6.4 Create the jUnit test
Add this code to the test java file (TestQuickstart.java):

@Test
public void getCarsFromOwnerTest() {
Owner owner = new Owner();
owner.setName("Phil Mean");
owner = quickstart.getCarsFromOwner(owner);
Set<Car> cars = owner.getCar();
assertEquals(1, cars.size());
Iterator<Car> i = cars.iterator();
Car car = i.next();
assertEquals("Black", car.getColor());
Model m = car.getCarModel();
assertEquals("Volvo", m.getManufacturer());
}

Generate the client code: right click the Domain Model and select Build Other Client.

Extend with new service
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6.5 Create the Service code
Add this code to the service java file (QuickstartImpl.java):

public Owner getCarsFromOwner(Owner owner) {
if (owc.containsKey(owner.getName())) {
return owc.get(owner.getName());
}
throw new NoSuchOwnerException("Sorry - There's no such owner..");
}

Generate the server code: right click the Domain Model and select Build Other Service.

6.6 Run the changed services
Stop the running server application and restart it.
Run the jUnit test.

Extend with new service
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